Insights and Leads are currently experiencing an outtage
Incident Report for Arcade Software
Resolved
This incident has been resolved.
Posted Feb 06, 2024 - 10:46 PST
Identified
We've identified an issue with our analytics backend, causing Insights and Leads to fail to load.
Posted Feb 06, 2024 - 10:43 PST
This incident affected: Arcade Analytics.