Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 01, 2025 - 10:00 PST
Scheduled
The full logged-in experience of the Arcade app (i.e. recording demos, editing Arcades, reviewing insights, managing teams) will be temporarily unavailable during this maintenance window as we upgrade our systems to support new functionality. During this time, all public Arcades will remain live and unaffected.
Posted Feb 26, 2025 - 12:58 PST
This scheduled maintenance affected: Arcade Extension, Flow Builder, Arcade Analytics, and GIF & Video Export.